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Dreamweaver MX 2004
Dreamweaver is the premier web editor application used to build professional websites 
and applications brought to you by Macromedia.

Objective

Understand the basics of how web pages work and how to create and publish pages to 
Evergreen’s web server using Dreamweaver.

Outline

Introduction (Overview and Outline)

Design and Planning

File Management and Server Information

Window Environment

Site Definition

Creating a New File

View Options

Introduction to Text

Page Title

Saving / File Management

Working with Images

Working with Links

Copy/Paste Text (see Intro to Text section)

Publish and Preview

Further Research
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Design and Planning

With the help of the World Wide Web Consortium (W3C) and Designers 
internationally standards and best practices have come into being. The development 
of the craft of Web Design offers key steps or guidelines in the process of creating  
websites.  We have condensed them into the following four points: purpose, content, 
wireframe, design.

1. Purpose
Why are you building this site... what is its purpose?
Who is going to be using this site... who is your audience?   

2. Content
What is the content?

Identifying the content and categorizing it into logical 
groupings can determine the layout of your site and the 
consistency of the pages therein.  This may come in the form of 
an outline, a series of topics, or a site map.

When determing where information should reside ask yourself:

What information would I find most useful?

What would be the most logical way to access that information?

How might someone get confused or frustrated when looking for specific 
information?

3. Wireframe
How might a sketch of the page layout look? 
How might a visitor find their way through your site?

Now the questions about usability and discovery of the ways 
to access the content  begin to flourish.  A layout skeleton 
of your site begins to be organically organized while paying 
attention to the user and levels of information they will need to 
sort through visually.  This may come in several forms: 

a very basic HTML text-based simulation that 
evolves into a full blown website (a traditional 
wireframe using boxes, links, and placeholders)

a storyboard you draw to show layout ideas

4. Design
After careful consideration of navigation elements (e.g. navigation menu or bar), 
color schemes, and typeface, by trial and error as well as user feedback, the actual 
visual design starts to develop.  Some designers create design compositions (or 
comps) of the web pages in Photoshop or elsewhere. Rarely does a designer get it 
right the first time around.
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File Management and Server Information

Understanding where your files are, both on your computer and on the Web server, 
will make Web Development and Dreamweaver much easier for you. When defining 
where you will be modifying your files, you must specify the folder you will be 
working in on your local computer.  This is also called the Local Site in Dreamweaver.  
The remote folder on the Web server defines the Web address.   This is also called the 
Remote Site in Dreamweaver.

HTML Pages

Dreamweaver is just one of many software applications that assist in creating 
HTML.  HTML or HyperText Markup Language is the ‘language’ that Web 
servers use to display Web pages.

You can save any Web page you like from most browsers by selecting File > Save 
As... .  This is an easy way to copy someone else’s color scheme or code. Any 
HTML page can be opened and edited using Dreamweaver.

Web Page Naming Conventions

While using Evergreen’s webspace, always save your homepage as home.htm.  It is 
essential that you always save your home page as the same name with the same file 
extension.  

To avoid confusion always be consistent in the extensions you use for saving your 
web pages.  At Evergreen, the standard is .htm.  That means that ALL your pages’ 
file names should end in .htm.  

Always name your pages in the following manner:

Use only lower case letters. Unix servers are case sensitive and recognize upper 
and lower case letters as having a different value (e.g., puppy.htm and Puppy.
htm would be considered two different files.)

Never leave spaces in the name!

Never use special characters such as periods, #, &, etc.

Stay away from underscores.  When made into a link, it is impossible to see the 
underscore in the filename. 

Name files logically. Give your webpages obvious file names that will 
adequately describe the contents of the page without being too lengthy.  It’s a 
good idea to keep your file names under 30 characters in length. 
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Home Page Naming Demystified:

When you first open your web account, your root folder already contains the page 
home.htm.  If you edit that page and then save it as home.html, you will have 2 pages in 
your root web folder, one called home.htm and one called home.html.  

The Evergreen Web server is set to default to home.htm as your home page. 
Evergreen’s Web server is also configured to default to the following home page file 
names in order as they appear in this list:

home.htm

home.html

default.htm

default.asp

index.htm

Parts of a Web Address

Web address is technically known as a URL or Uniform Resource Locator.  It is an 
address that points to a specific location on the Internet.  

Using the example http://www.evergreen.edu/curricular/wddfsi/home.htm 

A. http: //    protocol prefix with separators

B. www.evergreen.edu  server and domain name

C. curricular/   folder name

D. wddfsi/    subfolder name

E. home.htm   file name

Evergreen Web Servers

There is one main Web server that you will probably need to be familiar with.  The 
computer name for the server is Coyote.  Coyote is used primarily for Program Web 
Sites and Individual Web sites.  The primary host domain url for Coyote is academic.
evergreen.edu.

Note: When you create a Web page, you are working on your LOCAL computer and 
when you are ready to publish your page to the Web, you must publish (or copy) it to 
the appropriate Web server.

See the Diagram on the next page for a visual representation of Web Publishing at 
Evergreen and compare to what you’ve learned so far and the information below the 
diagram image.
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Web Publishing Diagram

Work Locally on your Web files!

Your Curricular Program Web Space

You will be assigned a folder webspace through your Academic Computing liaison.  

REMOTE
         Web Server

LOCAL
       Computer

in Dreamweaver

on Coyote

Site Folder (local root)

academic.evergreen.edu/curricular/programpage (remote root)

images

home.htm

images

home.htm
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Site Definition

This is the first thing  you must do once you open Dreamweaver and begin working on 
a website. Once you have set up a site on a specific (local) computer you do not need 
to define the site again.  If, however, you move to a new (local) computer you will need 
to define your site for that specific computer.

How to start and define a Site using the Advanced tab:

1. Select Site > Manage Sites > New > Site. 

ALERT: Do not select New > FTP & RDS Server!

2. Select the Advanced tab.

3. Define your local and remote settings:

Define Local Info:
Enter the name of your site next to Site Name:. For example: “Student 
Associates”.  This name is for your use only.

Choose a Local Root Folder that will contain all of your site’s files.  

Click the folder icon to the right of the Local Root Folder field.

Navigate to your Documents folder. You may need to click on 
the New Folder (Icon on PCs) in Documents and name the new 
folder.

Click Open.

Click Select.

Define Remote Info: (see image on next page)
Select FTP from the Access: drop-down list.  For FTP, first be sure you 
know the full Web address for your web space.

In the FTP Host box, type the IP address or name of the web server 
(i.e. academic.evergreen.edu).

In the Host Directory box, type the path to your web space folder (i.e. 
/s/smibet15 OR /curricular/program)

Type your Evergreen Login and Password in the appropriate boxes.

Click the Test button to verify you’ve entered the correct settings.  

4.  Click OK.  

5.  Click Done.

1.

2.

•

•
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6. From the Files Panel, click the Connect   button on the toolbar to connect 
to the remote host.

Fill out the following form to keep track of your “remote” information.

FTP Host:  academic.evergreen.edu           

Host Directory:  ______________________________________

Login: ________________________________________________ 
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Site Management

Dreamweaver has built-in file management tools when you define your sites.  In 
addition, developing an understanding of how sites are set up and how to manage (or 
keep track) of your files and folders within your site is a large part of learning web 
development. Most of your Site and File Management can be done in the Files Panel.

How to Edit Your Site 
Information:

1.  Select Site > Manage Sites...

2. Click on the Site you want to Edit.

3. Click Edit.  You can edit in the Basic or 
Advanced tab.

4. Click Done when Finished.

5. Click Done once more and changes are 
applied.

Note: You can delete your site settings by clicking on Remove.

Site Views (Local and Remote)

Use the Site View drop-down menu on the Files Panel 
to switch between your Local and your Remote.

You can also expand and collapse the Files Panel to 
access the Site window by clicking the button directly 
under the drop-down menu.

Understanding Paths

Your Local View should match your Remote View.  
For instance, the root folder  on your Local side 
should match the root folder and subsequent folder/file 
structure as your Remote side.  

ALERT: All files you are using in your site must reside in your Local 
root folder.

Manage Sites Window

This drop-down menu 
toggles between Local 
and Remote

This button expands 
and collapses the SIte 
Window View

Root Folder
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Creating a New File
As with most programs there are two or more ways you can create a new file in 
Dreamweaver.  Below are instructions for two ways, first the most common method.

Creating a New File from the File Menu

1. Select File > New...

2. On the “General” tab (shown at the top of the window), select “Basic Page” under 
the left “Category” column and HTML in the middle column. 

3. Check the “Make document XHTML compliant” checkbox on the bottom-right. 
Then, click Create. 

Note: You can also create a CSS stylesheet, or select any of the Page Designs to use a 
pre-made Dreamweaver HTML webpage file. 

Creating a New File from the Files Panel

1. Right-click (Ctrl+click for Mac users) on the folder 
where you want to create a new file in the Files Panel.  
This is also how you create a new folder.

Note: You could also select the folder and click on the 
sub-menu of the Files Panel and select File. 

2. Select New File.

3. Type in the name of your new file (or folder) with 
no spaces and include the extension (for example, home.htm, or style.css), then press 
Enter/Return.

Make sure this box is checked!
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View Options

There are three viewing and editing options in Dreamweaver that allow you either to work on 
your web document via the HTML code or via what you see on the web browser (WYSIWYG).

Viewing the HTML Code 

On the Document Toolbar (or from View on the Menu Bar), click Code.

Viewing Your Page As You Would See It On The Web 

On the Document Toolbar (or from View on the Menu Bar), click Design.

View The Code and Display Design in a Horizontal Split Screen

On the Document Toolbar (or from View on the Menu Bar), click Split and view your 
changes as they happen. 

•

•

•

Document Toolbar

code

design
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  Introduction to Text

Adding text to Dreamweaver is as easy as using a word processor program. 

Adding Text to your Document

1. Make sure you have created a new 
document or opened an existing document. 

2. Make sure you are in Design View.

3. Simply click in the document window.  A 
cursor will blink to indicate insertion point.

4. Start typing.

Using Headings
 
There a six Heading styles to choose from: Heading 1 - 6. Heading 1 will provide the 
largest size font and Heading 6 the smallest. 

1. Highlight the block of text you want to change to a Heading.

2. Using the Properties Inspector Panel, click on the Format drop-down menu arrows.

3. Select a Heading you want to use. If you don’t want a Heading, choose None or 
Paragraph. 

Copy / Paste Text
 

1. Highlight the block of text you want to copy from any application.

2. Select Edit > Copy (or Ctrl/Cmd + C).

3. Go to Dreamweaver and click in the area where you want to paste the text.

4. Select Edit > Paste (or Ctrl/Cmd + V).

New Document Window

Properties Panel
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Title

First things first, create a title for your page. This title is not actually “seen” on your 
webpage, other than on your browser title bar and sometimes in the header portion 
when the webpage printed. You can create a title for each individual page or use the 
same site title for all your pages in your site.  Although the title is acutally located 
in the “head” portion (between the <head></head> HTML tags) of your webpages, 
search engines can glean information from it.  It also shows up when a page is 
“bookmarked” or saved as a favorite in a browser. See image examples below. 

Creating a Title 

1. In the Title text window at the top of your document (i.e. home.htm) on the 
document toolbar, type a title.

2. Alternately, go to Modify > Page Properties to see the page property options.

3. In the Title field of the Page Properties dialog box, type the title of your 
choosing to identify your site and the page for your users.  Click OK.

Title

Document ToolbarTitle

Dreamweaver

Safari Browser
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  Saving

Save first and save often! Dreamweaver has been known to crash at times.  Like any 
program that is memory intensive, it’s best to keep your left (or right) hand ready to do 
the keyboard shortcut for SAVE -- Cmd + S (Ctrl + S for PC user).

In Dreamweaver, on the title bar of your document, notice the asterisk when your 
document is not saved. 

Saving a New File 

1. In the document window, choose File > Save.

2. Make sure you save your document in your site folder.

3. Save your document consistently with either an .htm or .html extension. No 
spaces, you can use the _ underscore if necessary. The shorter the file name the 
better.

4. Click OK. 

Saving a Copy of your File

1. Select File > Save as...
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  Working with Images

Dreamweaver makes inserting images, rollover images and creating image maps easy. 

Inserting an Image 

1. Click your cursor where you’d like to place an image.

2. Select Insert  > Image or use the Image button  on the Common Window of the Insert Panel.

3. Locate an image file in the images folder of your site.

4. Click OK.

5. In the Alt field, add an Alt tag to the image by typing in a title for the image. The Alt tag 
specifies alternative text that appears in place of the image for text-only browsers or for browsers 
that have been set to download images manually. For visually impaired users who use speech 
synthesizers with text-only browsers, the text is spoken out loud. 

Note: Changing the size of an image in the Dreamweaver window does NOT change the file 
size.  To effectively resize and optimize an image, you must use an image editing program like 
Photoshop.

Rollover Images

A rollover image is an image whose display changes when the pointer is ‘rolled’ over it.  A 
rollover is created by attaching a “behavior” to an image.

1. Click your cursor where you’d like to place a rollover 
image.

2. From the Common Insert Panel dropdown select Insert 
Roll-over image 

    - Type the name of this rollover object in the image name

    - Browse to the original image and then the roll-over image

    - Give it an Alt text tag and provide the page that this 
rollover is linked to.

Alt field



pg. 15Dreamweaver MX 2004
Working with Images

The Evergreen State College

3. Preview in a browser. 

Image Maps
 

1. Select an image by clicking once on it.

2. In the Properties Panel, select a shape for the image map from the shapes available under the Map 
name field on the lower left.

3. Draw the area on the image that will become a link.  Move the selected area using the arrow keys.

4. With the Image Map area selected, use the Properties Panel to specify the name of the file to link 
to, the map name, and the Alt tag.  

5. You can alternatively click on the folder icon next to the link box 
or use the point to file icon to specify the local file to link to.  If it will 
be an absolute link, put the entire web address in the link field.

6. Preview in a browser.  The cursor should change to a hand over 
the ‘hot’ spots in your image, indicating a link.
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  Working with Links

A link, or hyperlink, is a reference in a hypertext document to another document or 
resource. Creating links in your site is an important activity for any web developer. 
What would HTML be without hypertext? 

Absolute versus Relative Links

1. An absolute link uses a complete path name to locate a file. 

For example: http://access.wa.gov

An absolute link does not change when the page that links to it moves.  (This is like 
putting a stamp on a letter to your next door neighbor, putting it into the mailbox, 
having it go downtown to be sorted, and delivered to your neighbor.)

2. A relative link is created in relationship to the referencing document.  For 
example: images/geoduck.gif     or      links.htm

A relative link can change if you move the referencing document.  (This is like 
walking a letter over to your neighbor’s house.)

This explanation is highly simplified.   There are a variety of conventions to learn 
that will aid you in choosing the correct link.

3. How Do I Know Which to Use?

A rule of thumb for absolute links:  Whenever the link is not on the same server, 
it is absolute. 

All files within your site folder should be relative links.

Files on the same server, but not in your site can also be relative links, but will 
work as absolute links as well.  For our purposes, we will use absolute links for 
all files outside of our personal folders.

How to Create an Absolute Link: 
 

1. Highlight the text or click on the image you want to become the link.

2. Go down to the Properties Panel and click in the Link box and type the address 
making sure to include http://.  Example: http://www.evergreen.edu

•

•

•

Link field
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How to Create a Relative Link:

1. Highlight the text or image you want to become the link.

2. Use the Properties Window to specify the name of the file to link to.  In this case, type 
‘syllabus.htm’ in the link box.  We will actually create this page later in the workshop.

3. You can also click on the folder icon next to the link box or use the point to file icon to 
specify the local file to link to.

How to Create a Named Anchor:

Anchors allow you to link to section further down in the current page or to a particular 
spot on another page.

1. Place the cursor insertion point where you want a named anchor (right in front of 
Week 1 on the syllabus).

2. Choose Insert > Named Anchor or use the Named Anchor button from the Common 
Insert Panel.

3. In the Anchor Name field, type a name for the anchor.

4. Go to the place where one will click to link to the anchor and highlight the text or 
image you want to link.

5. In the Link text box of the Property inspector, type a number sign (#) and the name 
of the anchor you provided in step 3 above (no spaces).

Note: Anchor names are case sensitive and require no spaces.
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  Preview & Publish

Dreamweaver offers the opportunity to both preview your page in a web browser and 
upload your page for publishing. 

How to Preview your Page on a Browser:

1. Select File > Preview in Browser > Firefox. Or, you can choose another 
browser like Safari or Internet Explorer.

How to Publish Your Page or Site:

1. Select the file(s) in the Files panel, or 
your Local Root folder at the top of the 
Files panel. 

2. Press the blue Put arrow button  on 
the toolbar.

3. Choose Yes when asked to copy 
all dependent files.  This eliminates the 
need to publish all images and other files 
separately from your HTML file.

Moving Files Between Local and Remote 
 
There are three methods for moving files between the twin Local and Remote sites: 
Get, Put and Synchronize (discussed on next page). These are all done in the Files 
panel.

The green Get arrow button moves files from the Remote to the Local.  This 
command can be applied to an entire site, to a group of selected files within a 
site or to a single selected file.

The blue Put arrow button moves files from the Local to the Remote site.

Note: The GET and PUT commands can be applied to an entire site, to a group of 
selected files within a site or to a single selected file.

1. When you select the Get or Put command, Dreamweaver will ask if you want to 
move all associated files.  

If you have made text or formatting changes only, you can safely choose “no.”  

•

•

•

Use drop-
down menu
to change 
between Local 
and Remote 
Views
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However, if you have added images or changed a template, you should choose “yes.”  
Choosing “yes” in either circumstance will not cause problems.

2. Dreamweaver understands Associated Files to mean:

Images

Templates

Folders used for organizational purposes

Other linked documents (word, pdf, css, js, etc)

3. Use the drop-down menu at the top-right of the panel to change between Local and 
Remote View to get or put.  

Note: Always work and edit your pages in Local View.  Get your page files from Remote 
is needed.

How to Synchronize Your Site:

The Synchronize function examines the time 
stamp associated with each file and moves 
the most recent one where needed (remote 
or local).  This command applies to the 
complete site.

1. In the Files Panel submenu, select Site > 
Synchronize... command examines the time 
stamp associated with each file and moves 
the most recent one where needed.  

2. Using the top Synchronize drop-down, select Entire ‘Your Site’ Site.

3. Then, if you only need to ‘Get’ the newest files from the Web server, choose Get 
newer files from remote next to Direction.

Note: If you want to delete pages from your site, delete them in your Files Panel 
Local View and then select the option “Delete remote files not on local drive“ when 
synchronizing.

•

•

•

•

•
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  Further Research

Where to go from here... 

Links

Dreamweaver 

www.macromedia.com

www.uensd.org/manuals/

www.learnthat.com/courses/viewlets/dreamweaver/ 

General Web Design

www.useit.com

www.lynda.com

www.leafdigital.com/class

www.webstyleguide.com

www.csszengarden.com

www.webmonkey.com

Books 
 
Dreamweaver MX QuickStart Guide – PeachPit Press

Eric Meyers on CSS

Macromedia Dreamweaver MX Hands on Training (Lynda.com)

Dreamweaver MX: The Missing Manual


