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Site Definition

When starting a project in Dreamweaver the first thing to do is Define a Site.  
Defining a site involves designating where to save files on the local computer and 
where they are stored on the remote server.

How to Define a Site Using the Advanced Tab:

1. Select Site > New Site. 

2. Select the Advanced tab.

Define Local Info:
Enter the name of your site next to Site Name. For example: “SOS 
Media”.  This is only for your reference.

Designate a local root folder that will contain all of the site’s files.  

Click the folder icon to the right of the Local Root Folder field.

Navigate to a location on the computer to store site files. You 
may need to create a new folder. 

Click Open.

Click Select.

Define Remote Info:
Click Remote Info from the left column.

Select FTP from the Access: drop-down list.  

In the FTP Host box, type the name of the web server (i.e. academic.
evergreen.edu) or the IP address.

In the Host Directory box, type the path to your web space folder (i.e. 
/s/smibet15 OR /curricular/program)

Type your Evergreen Login and Password in the appropriate boxes.

Click the Test button to verify you’ve entered the correct settings.  

4.  Click OK.  

5. From the Files Panel, click the Connect   button on the toolbar to connect to the 
remote server.

1.

2.

•

•

•

•

1.

2.

3.

4.

5.

6.



pg. �Dreamweaver 8
Web Design 

The Evergreen State College

Site Management

 The most important skill in web development is file management.   Having files named 
properly and organized for easy retrieval is essential.  Most site and file management 
can be done through the Files Panel.

How to Edit Site Information:

1.  Select Site > Manage Sites...

2. Select the site to be edited.

3. Click Edit.

4. Click Done when Finished.

5. Click Done once more and the changes are 
applied.

Note: Reset site settings by clicking on 
Remove.

Site Views (Local and Remote)

Use the Site drop-down menu in the Files Panel to 
switch between viewing local files on the computer and 
remote files on the server.

The file panel can also be expanded to view local and 
remote files side by side by clicking the button directly 
under the drop-down menu.

Understanding Paths

The Local View should mirror the Remote View.  While 
working on a site work on the local site off-line.  When 
you are done connect to the remote server and Put 
(the blue up arrow) files on the remote site to post the 
changes.

ALERT: All files that are used in a site must reside in the Local root 
folder.

Manage Sites Window

Drop-down menu 
toggles between Local 
and Remote

This button expands 
and collapses the Site 
Panel to view files side 
by side

Local Root Folder
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Creating a New HTML Page

Creating a New HTML Page from the File Menu

1. Select File > New...

2. In the “General” tab select Basic Page under “Category” and HTML from the 
second column.

3. In the “Document Type” pull-down (lower right), confirm that XHTML 1.0 
Transitional is selected. Click Create. 
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Window Environment

 The essential elements in the Dreamweaver workspace are: 

Menu

Insert Toolbar 

Document

Property Inspector

Files Panel

If a panel is not already visible, select it from the Window menu.

Property Inspector
This is used to view and modify properties of the currently selected object or text.  

Adjusts attributes such as links,  font style, color, etc.

Files Panel
As a site is built, the file structure is displayed here. Use this panel to switch 
between remote (files on the server) and local views.

DREAMWEAVER WORKSPACE

Property Inspector

New Document Window

Insert Toolbar

Files Panel

Document Toolbar

Menu
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View Options

There are three viewing and editing options in Dreamweaver.  Code View works directly with 
HTML code to create and edit documents.  Design View is a visual editor that represents 
what will be shown in a web browser (WYSIWYG). Split View displays Code and Design 
simultaneously.

Viewing the HTML Code 

On the Document Toolbar click Code.

Viewing A Page As Would Appear On The Web 

On the Document Toolbar click Design.

View The Code and Design Views Simultaneously

On the Document Toolbar click Split to view changes to either side as they happen. 

•

•

•

Document Toolbar

code

design
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Adding Text

Working with text in Dreamweaver is much like using a word processor program. 

Adding Text to a Document

1.  	Create a new document or open an existing one. 

2. 	 Select Design View.

3. 	 Click inside the document window.

4. 	 Start typing.

Using Headings
 
There are six Heading styles to choose from. Heading 1 provides the largest size font and 
Heading 6 the smallest. 

1. 	 Highlight a block of text.

2. 	 In the Properties Inspector, click on the Format drop-down menu arrow.

3. 	 Select a heading style. 

4. 	 To remove a heading, choose None or Paragraph. 

Copy / Paste Text
 

1. Highlight a block of text  from any application.

2. Select Edit > Copy (or Ctrl/Cmd + C).

3. In Dreamweaver, position the cursor where the text will be inserted.

4. Select Edit > Paste (or Ctrl/Cmd + V).

Property Inspector
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  Working with Links

A link, or hyperlink, is a reference in a web document to another document or 
resource. Creating links in a site is an important activity for any web developer. 

Absolute versus Relative Links

1. An absolute link uses a complete path name to locate a file. 

For example: http://access.wa.gov

An absolute link does not change when the page that links to it is relocated.  (This 
is like putting a stamp on a letter to your next door neighbor, putting it into the 
mailbox, having it go downtown to be sorted, and delivered to your neighbor.)

2. A relative link is created in relationship to a referencing document.  For 
example: images/geoduck.gif     or      links.htm

A relative link will need to be updated if the referencing document is moved.    
There are a variety of conventions to learn that will assist in selecting the correct 
format for a link.

Which Links To Use When...

A rule of thumb for absolute links:  Whenever the link is not on the same server, it 
should be absolute. 

All links to files within the same site folder should be relative links.

Files on the same server, but not in the same site, can be relative links and also 
work as absolute links. For now, use absolute links for all files outside of the site 
folder.

How to Create an Absolute Link: 
 

1. Highlight text or select an image to be used as the link.

2. In the Property Inspector, click in the Link field and type the complete address 
(or copy and paste the URL from that website).  Example: http://www.evergreen.edu

•

•

Link field

Point to file
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How to Create a Relative Link:

1. Highlight the text or image.

2. In the Property Inspector type the name of the file to link to.

3. Another method is to click on the folder icon next to the link box or use the point to 
file icon to specify the local file to link to (see graphic on previous page).

How to Create a Named Anchor:

Anchors link to a section further down in the current page or to a particular spot on 
another page.

1. Place the cursor where the named anchor will be.

2. Choose Insert > Named Anchor.

3. Type a name in the Anchor Name Field.

4. Highlight the text or image the anchor will link to.

5. In the Link text box of the Property inspector, type a number sign (#) and the name 
of the anchor you provided in step 3 above (no spaces).

Note: Anchor names are case sensitive and require no spaces.
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  Working with Images

Images should be re-sized and compressed in an image editor, such as Photoshop, before bringing 
them into Dreamweaver.  Changing the size of an image in Dreamweaver does NOT change the file 
size.

Inserting an Image 

1. Click the cursor where an image is to be placed.

2. Select Insert  > Image.

3. Select an image file. 

4. Click OK.

5. Add an Alt Tag to the image by typing in a title for the image in the Alt Field, . The Alt tag 
specifies alternative text that appears in place of the image for text-only browsers or for browsers 
that have been set to download images manually. The text is spoken out loud for visually 
impaired users who use speech synthesizers with text-only browsers. 

Rollover Images

A rollover is an image whose display changes when the cursor is placed over it.  A rollover is 
created by attaching a “behavior” to an image.

1. Click the cursor in the place where the rollover image will be.

2. From the Insert Panel drop down select Insert Roll-Over Image 

    - Type the name of the rollover object in the name field.

    - Browse to the original image and then the roll-over image

    - Specify an Alt text tag and locate the page that this 
rollover is linked to.

3. Preview in a browser. 

Alt field
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Image Maps
 

1. Select an image.

2. In the Property Inspector select a shape for the image map from the list.

3. Draw around the part of the image that will become a link.  Move the selected area using the 
arrow keys.

4. With the Image Map area selected, use the Property 
Inspector to specify the name of the file to link to, the map 
name, and the Alt tag.  

5. Another method is to click on the folder icon next to the link 
box or use the point to file icon to specify the local file to link up 

with.  If it will be an absolute link, put the entire web address in the link field.

6. Preview in a browser.  The cursor should change to a hand over the ‘hot’ spots in your image.
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  Saving

Save first and save often! Dreamweaver has been known to crash at times.  Like any 
program that is memory intensive, it’s best to keep your left (or right) hand ready to do 
the keyboard shortcut for SAVE -- Cmd + S (Ctrl + S for PC user).

When there is an asterisk next to the name on the title bar of your document it means 
that the document has not been saved.  

Saving a New File 

1. In the document window, choose File > Save.

2. Confirm that the document is being saved into the correct site folder.

3. Save the document consistently with either an .htm or .html extension. No 
spaces.  Use _ underscore if necessary. The shorter the file name the better.

4. Click OK. 

Saving a Copy of your File

1. Select File > Save as...
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  Preview & Publish

Previewing is viewing a mock up of a local web page as it would appear on the web.  
Publishing is posting the local files to the remote web server.  Previewing can be 
deceiving as some attributes will appear differently when published to the actual web 
server. Pages will also be interpreted differently by each  different web browser.  For 
quality control publish the site to the web and test on multiple browsers.    

Preview a Page In a Browser:

1. Select File > Preview in Browser > Firefox.   Different browsers can be 
selected such as Safari or Internet Explorer.

How to Publish a Page or Site:

1. Select the file(s) in the Files panel, or 
your Local Root folder at the top of the 
Files panel. 

2. Press the blue Put arrow button  in the 
toolbar.

3. Choose Yes when asked to copy 
all dependent files.  This eliminates the need to publish all images and other files 
separately from your HTML file.

Moving Files Between Local and Remote 
 
There are three methods for moving files between the mirrored Local and Remote 
sites: Get, Put and Synchronize. These are all done in the Files panel.

The green Get arrow button copies files from the web server to the local 
computer.  This command can be applied to an entire site, to a group of selected 
files within a site or to a single selected file.

The blue Put arrow button copies files from the local computer to the 
webserver.

•

•

Use drop-
down menu
to change 
between Local 
and Remote 
Views
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1. When the Get or Put command is selected Dreamweaver will ask if all associated files 
should also be copied.  

If only text or formatting changes have been made select “No”.

If images have been added, or a template has been changed, choose “Yes.”  Choosing 
“yes” in either circumstance will not cause problems.

2. Associated Files are:

Images

Templates

Folders

Other linked documents (word, pdf, css, js, etc)

3. Use the drop-down menu to change between Local and Remote View to Get or Put.  

Always work and edit your pages in Local View.  Get files from Remote as needed and 
disconnect once you have copied the files 
needed to the local computer.

How to Synchronize A Site:

The Synchronize function examines the 
time stamp associated with each file and 
moves the most recent version where needed 
(remote or local).  This command applies to 
the entire site.

1. In the Files Panel submenu, select Site > Synchronize...

2. Using the Synchronize drop-down menu, select Entire Site.

3. If only the newest files are needed from the web server choose “Get Newer Files From 
Remote” next to Direction.

Note: If pages need to be deleted from the site, delete them in the Files Panel Local 
View and then select the option “Delete Remote Files Not On Local Drive“ when 
synchronizing.

•

•

•

•

•

•


